home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-apps / coldplug-20040920 / coldplug-20040920.ebuild < prev    next >
Text File  |  2005-10-18  |  841b  |  26 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-apps/coldplug/coldplug-20040920.ebuild,v 1.9 2005/10/16 15:51:52 kumba Exp $
  4.  
  5. inherit eutils
  6.  
  7. # source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
  8. MY_P=hotplug-${PV:0:4}_${PV:4:2}_${PV:6:2}
  9. S=${WORKDIR}/${MY_P}
  10. DESCRIPTION="coldplug init.d program to load modules at bootime"
  11. HOMEPAGE="http://linux-hotplug.sourceforge.net"
  12. SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
  13.  
  14. SLOT="0"
  15. LICENSE="GPL-2"
  16. KEYWORDS="x86 ppc sparc alpha ~hppa amd64 ia64 mips ~ppc64"
  17. IUSE=""
  18.  
  19. # hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
  20. DEPEND=">=sys-apps/hotplug-20040920"
  21.  
  22. src_install() {
  23.     exeinto /etc/init.d
  24.     newexe ${FILESDIR}/coldplug.rc coldplug
  25. }
  26.